Remove ugly hack that breaks su/sudo on upgrades.
Daniel Hokka Zakrisson [Wed, 29 Dec 2010 16:50:19 +0000 (11:50 -0500)]
vserver-reference.spec

index 06b334d..80167e3 100644 (file)
@@ -46,7 +46,6 @@ Summary: VServer reference image
 Group: Applications/System
 AutoReqProv: no
 Requires: util-vserver, e2fsprogs, yum
-Requires(pre): util-vserver-core, findutils
 
 %description %{slicefamily}
 This package creates the virtual server (VServer) reference image used
@@ -98,12 +97,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %define vcached_pid /var/run/vcached.pid
 
-# XXX: UGLY HACK
-%pre %{slicefamily}
-test -d /vservers/.vref/%{slicefamily} && \
-   find /vservers/.vref/%{slicefamily} -print0 | xargs -0 setattr --~iunlink
-:
-
 %post %{slicefamily}
 chkconfig --add vserver-reference
 chkconfig vserver-reference on