fix rpm-build dependency problem
S.Çağlar Onur [Fri, 17 Dec 2010 18:13:42 +0000 (13:13 -0500)]
kernel-2.6.spec

index 70cc209..2513a7b 100644 (file)
@@ -563,7 +563,13 @@ Obsoletes: kernel-smp
 BuildRequires: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
 BuildRequires: bzip2, findutils, gzip, m4, perl, make >= 3.78, diffutils, gawk
 BuildRequires: gcc >= 3.4.2, binutils >= 2.12, redhat-rpm-config
+#### Planet-Lab ####
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 14
 BuildRequires: net-tools, patchutils, rpm-build >= 4.8.0-7
+%else
+BuildRequires: net-tools, patchutils, rpm-build
+%endif
+#### Planet-Lab ####
 %if %{with_doc}
 BuildRequires: xmlto
 BuildRequires: asciidoc