older modutils do not support --package and --update option
S.Çağlar Onur [Wed, 2 Feb 2011 22:28:41 +0000 (17:28 -0500)]
kernel-2.6.spec

index 3c9b85e..99acf8c 100644 (file)
@@ -1556,7 +1556,11 @@ fi\
 %if %{with_dracut}\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --mkinitrd --dracut --depmod --update %{KVERREL}%{?1:.%{1}} $NEWKERNARGS || exit $?\
 %else\
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --mkinitrd --depmod --update %{KVERREL}%{?1:.%{1}} $NEWKERNARGS || exit $?\
+%else\
+/sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}%{?1:.%{1}} || exit $?\
+%endif\
 %endif}\
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12\
 /sbin/new-kernel-pkg --package kernel%{?1:-%{1}} --rpmposttrans %{KVERREL}%{?1:.%{1}} || exit $?\